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About GalleryData

GalleryData is a member of the Label Gallery family, which forms a new generation of
program equipment for designing and printing labels. GalleryData is a simple program,
designed for managing databases. Program allows elaboration of tables, changing structures,
renewal of indexes, automatic filling and deleting data.

Program supports Paradox, dBase, Access and tables of ASCII type. You can also access
other database types via ODBC or BDE interfaces.

GalleryData is a standard 32-bit Windows application.
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User Interface
Main Window

Status Bar

Status bar provides useful information about the current status of the application, indexes and
position in the database.

Table Area
Work with the data in this area.

Main Window
@ GalleryData - [C:\Program Files\SatodMGallery 2¥SamplesiData... |:||E|r>__(|
E[L., File Edit ‘iew Tools Window  Help - F X -
R EIRD e SR e = B
: Hr Tahoma ~ 10 v

NAME POSITION ROOM|PICTURE D | ~
lm System Analysts 502  linda.wmf 101
_[Cindy Grey General Manager 500 |cindy.wmf 100
_|Jennifer Jones Secretary 501  jennifer.wmf 105
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Main window

Customizing the Software

To change the font used in the table, do the following:
1. Select Font command in the Options menu.
2. Select the appropriate font.

To customize the menus and toolbars, do the following:
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1. Select Customize command in the Tools menu.
The Customize dialog box will open.

2. Make modifications to the settings.
3. Click on the OK button.

Note:
You can also change the positions of the toolbars on-screen. Just drag them to the new
position.
Shortcuts
Shortcut Action
Multi select: The option selects all fields in the record. This
Cul+M

<Insert> or <Arrow
down> on the last field

<Ctrl> + <Delete>
<F2>
<F8&8>
<F9>

functionality can also be used to copy values to another
application.

Insert new field in the database.

Delete the selected record.
Edit the selected field.
Switch between table and record views.

Switch between edit and view modes.
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Using Toolbars

Using Navigator Toolbar

Click on the icons in the toolbox to activate the following commands.
Button Action

I

-

Go to first record

Go to previous record

Go to next record

Go to last record

Insert a record

Delete a record

Confirm the changes in a record

Cancel the changes in a record

Using Text Toolbar

Click on the icons in the toolbox to activate the following commands.

Icon

Action

|fﬁ3 Arial

o ]

Select the font point size.

Click on this icon to use the bold text.

Click on this icon to use the italic text.

Using Toolbox

Click on the icons in the toolbox to activate the following commands.

Icon Action

Create a new database.

-] Select the font that will be used to display the data in the table.
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Open database table.

Save data to the database.

Cut to clipboard.

Copy to clipboard.

Paste from clipboard.

Create a table report.

Change the view to Table/Record.

Open help file.

B =] 7 & & & B [Z 3

Restructure the table.

Available Data Types for Fields

The following data types are available for fields:

A or C - alphanumeric field

N - number in signature with a floating comma

S - integers in range -32768 to 32767

I - long integers. Paradox long integer fields are 32-bit signed integers that contain
whole numbers (non-fractional) with complete accuracy in the range -2147483648 to
2147483647 (plus or minus 2 to the 31* power). Long integer fields require more
space to store than short fields.

L - logical value TRUE, FALSE

D - date

T - time

@ - timestamp

Defining Indexes

To define an index in the database table, do the following:

Note:
Indexes are not available for text database (. TXT, .CSV), but only for real databases
(MS Access, Paradox, dBase).

1. Open your database table.

2. Select the command Restructure in the Options menu.
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Note:
You can also click on the icon in the toolbox.
Go to the Indexes tab.
4. Click on the Add button.
Click on the field in the Fields in table box for which you want to define the index.

e

6. Click on the button to move the field to the Indexed fields box.
7. Click on the Save button.

8. Select the name for the index. You can leave the default setting.

9. Click on the OK button.

10. Click on the OK button to close the Indexes tab.

Notes for Paradox tables:

In order to design secondary indexes, table must have defined primary index. One of the
fields has to be set as a primary index.

Do the following:
1. Open your database table.
2. Select the command Restructure in the Options menu.
Note:
You can also click on the icon in the toolbox.
Go to the Fields tab.
4. Select the field for which you want to define the primary index.

Double click the Index area.
The asterisk character is placed in the Index area.

6. Continue with step 3 from the previous instructions.

Notes for dBase tables:

Only single field indexes are allowed for dBase tables.

Editing Data in the Table

Data in the table can be edited when a table is opened in the read / write mode. Make sure the
records are not displayed in the gray color indicating the table is set to View mode, not Data
mode.

To edit the data in the table, use the following methods:

1. Use cursor keys to move between fields in the table. The active record or field is
highlighted.

2. Whenever you want to change data, you simply write in the desired text.
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Note:
If you cannot edit the data in the table, make sure the table is not locked by some other

application and that you have enabled the Edit mode.

3. Entire record can be deleted by pressing a keyboard shortcut <Ctrl> + <Delete>.
Note:
You can also click on the = icon in the database navigator toolbar.

4. To insert a new field, press the <Insert> key or press <Arrow down> key on the last

field in the table.

Note:
You can also click on the ¥ icon in the database navigator toolbar.

Enabling Edit Mode

If the records in the database appear in the grey color and you cannot edit the records, you
have the database opened in the View mode.

To be able to make changes to the records, do the following:

1. Select the Edit command in the View menu.

Note:
You can also press the <F9> shortcut.

2. The table has switched to the Edit mode, enabling you to edit records.

Restructure the Database

To change the structure in your database table, do the following:
1. Open your database table.

2. Select the command Restructure in the Options menu.

Note:
You can also click on the icon in the toolbox.

3. Go to the Fields tab to make changes to the structure of the fields.
4. Go to the Index tab to make changes to the indexes.

5. Click on the OK button.




Automating the Software

Command line options

If you want to execute some commands when GalleryData starts, you can specify additional
command line parameters.

Command line parameters are:

Fill table:

-F output_table input_table [/Saaa] [/Tbbb]

Output table is filled with the records from the input table.

/Saaa  Optional parameters to check record size where aaa is record length.

/Tbbb  Optional parameter to skip records where bbb is the number of records you want to
skip.

Append table:
-A output_table input_table [/Saaa] [/Tbbb]
Records from input table are added to the output table.

/Saaa  Optional parameters to check record size where aaa is record length.

/Tbbb  Optional parameter to skip records where bbb is the number of records you want to
skip.

Append and update table:
-AU output_table input_table [/Saaa] [/Tbbb]

Records from the input table are added to the output table. If the same record already exist in
the output table, it is updated.

/Saaa  Optional parameters to check record size where aaa is record length.

/Tbbb  Optional parameter to skip records where bbb is the number of records you want to
skip.

Open table:

-D table name or just table name (without -D)

Empty table:
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-E table _name

This command can also be combined with append command (-AE). In this case the table is
first emptied and then the records from the input table are appended to it.

Opens table in table view:
-G

Opens table in record view:
-L

Quit GalleryData:
-Q

Do not report any errors:
-E

Example:
NDATA4.EXE -F ARTICLES.DBF IMPORT.TXT -Q

This command line converts a text file into dBase table. The indexes that may exist in the
output table are not recreated. After the process is finished, GalleryData closes.







Technical Support

Contact Information
Sato International Pte. Ltd.

438A, Alexandra Road, #05-01/02
Alexandra Technopark,

Singapore 119967

Tel: 65-6271-2122

Fax: 65-6271-2151

Sales: sales(@sato-int.com

Technical Support: softwaresupport@sato-int.com

Website: http://www.satoworldwide.com

Sato America Inc.

10350 Nation Ford Road Suite A
Charlotte, NC 28273
Tel: 1-704-644-1650
Fax: 1-704-644-1662

Sales: sales(@satoamerica.com

Technical Support: techsupport@satoamerica.com

Website: http://www.satoamerica.com

Sato UK Ltd.

Valley Road, Harwich, Essex England
Col12 4RR, United Kingdom

Tel: 44-1255-240000

Fax: 44-1255-240111
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Sales: enquiries(@satouk.com

Technical Support: techsupport@sato-uk.com

Website: http://www.sato-uk.com

Sato Europe NV

Leuvensesteenweg, 369
1932 Sint-Stevens-Woluwe
Brussels, Belgium

Tel: 32 (0) 2-788-80-00
Fax: 32 (0) 2-788-80-80

Sales: info@be.satoeurope.com

Technical Support: technical.support@be.satoeurope.com

Website: http://www.sato-europe.com

Sato Deutschland GMBH

Schaberweg 28, 61348
Bad Homburg, Germany
Tel: 49-6172-68180
Fax: 49-6172-6818-199

Sales: info(@de.satoeurope.com

Technical Support: softwaresupport@sato-deutschland.de

Website: http://www.sato-deutschland.de

Sato Polska SP Z O. O.

ul. Wroclawska 123

55-015 Radwanice k/Wroclawia, Poland
Tel: 48-71-381-03-60

Fax: 48-71-381-03-68

Sales: biuro@pl.satoeurope.com
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Technical Support: technical.support@be.satoeurope.com

Website: http://www.sato-europe.com

Sato France s.a

Parc D'Activities

Rues Jacques Messager
59175 Templemars, France
Tel: 33-3-20-62-96-40
Fax: 33-3-20-62-96-55

Sales: info@fr.satoeurope.com

Technical Support: technical.support@be.satoeurope.com

Website: http://www.sato-europe.com

Sato Asia Pacific Pte. Ltd.

438A, Alexandra Road, #05-01/02
Alexandra Technopark,

Singapore 119967

Tel: (65) 6-271-5300

Fax: (65) 6-273-6011

Sales: sales(@satoasiapacific.com

Technical Support: technical@satoasiapacific.com

Website: http://www.satoasiapacific.com

Sato Shanghai Co. Ltd.

307 Haining Road, ACE Building
10 Floor, Hongkou Area
Shanghai, China 200080

Tel: (86) 021-63068899

Fax: (86) 021-63091318

Index
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Sales: sales(@satochina.com

Technical Support: technical@satoasiapacific.com

Website: http://www.satochina.com

Sato Auto-ID Malaysia Sdn. Bhd.

No. 25, Jalan Pemberita U1/49

Temasya Industrial Park

Section U1, 40150 Shah Alam, Selangor Darul Ehsan
Tel: 60-3-7620-8901

Fax: 60-3-5569-4977

Sales: sales@satosms.com.my

Technical Support: technical@satoasiapacific.com

Website: http://www.satoasiapacific.com

Sato Auto-ID (Thailand) Co. Ltd.

292/1 Moo 1 Theparak Road, Tumbol
Theparak, Amphur Muang
Samutprakarn 10270

Tel: 662-736-4460

Fax: 662-736-4461

Sales: sales@satothailand.co.th

Technical Support: technical@satoasiapacific.com

Website: http://www.satoasiapacific.com

Online Support

You can find the latest builds, updates, workarounds for problems and Frequently Asked
Questions (FAQ) under the Support section on our Web site at www.satoworldwide.com. If
you cannot solve the problem on your own, please contact your local vendor or representative
offices listed in the topic Contact Information.
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For more information please refer to:

e Label Gallery FAQ:
http://www.satoworldwide.com/labelgallery/support faq general.htm

e Label Gallery eHelp: http://www.satoworldwide.com/labelgallery/support_ehelp.htm
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